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‘Surviving and Thriving during a recession’

I think it’s safe to say that last year we were all pretty happy and making money.  Our industry was in the midst of arguably 
one of steel’s greatest bull markets in decades.  
 
Here we are a year later and most experts are saying that the market has fallen even further than predicted and suggest that the steel 
industry needs to prepare itself for a tough road ahead.  

To help plan this path of recovery, even survival, we need to return to our roots and to the basic fundamentals of good business.

A quick search on Google for the phrase “recession proof” produces more than five million results. This tells us that obviously the blight 
of the economy has caused many to adopt a defensive position when it comes to their finances, 
careers, and life – I suppose - all for good reason.  

Every day the media is plagued with news of layoffs, cutbacks and economic stress.  Despite 
this doom and gloom, I believe we needn’t follow the grim attitude of the masses.

It is an established truth that the economy fluctuates.  Economists suggested these fluctuations 
move in cycles, or periods of rapid economic growth and periods of decline.  Some believe that 
the recession is a necessary evil that is designed to “clean the ‘fat’ out of the system, mop up 
excess, and pave the way for the next expansion.”   

As painful as it is, a recession is a natural part of the economic cycle .

Of course, this knowledge doesn’t ease the real-life difficulties facing us today. 
                                                                                                                                 (cont. p.3)

Tekla Structures BC User 
Day 2009

We want to express our sincerest appreciation to 
everyone who attended our BC User Day last May 
1st, 2009. Special thanks to those who traveled 

from as far as Nanaimo and Parksville and even St-Romuald, Que-
bec to join us for the day.  

The event that was held at our new digs was a huge success. Tekla 
Structures users flocked to the ‘whole day’ event and took advantage 
of the valuable topics and information discussed during the day’s 
sessions. I trust everyone also enjoyed the fellowship that followed 
after as much as we did.  

For those of you who missed the event, video recordings of the 
sessions are available at our website – www.dowcotech.com/bc_
ud2009.  By popular demand, the presentations are also available for 
download at that page.  

Lastly, we want to thank Tekla Inc particularly Mark Allphin, Steel 
Segment Manager for the US for graciously attending and speaking 
on behalf of our counterpart in the South.  

It is always a pleasure meeting and hearing everyone’s opinion and 
feedback on Tekla Structures and our services. Your continued par-
ticipation and support truly inspires us to continue to be exceptional.

Ewen Dobbie, President

Tekla Structures Model Reviewer 
Tekla Structures Model Reviewer user interface
     
Tekla Structures Model Reviewer is a new and improved tool based on 
the Tekla Structures Web Viewer. 

   
Model Reviewer makes project communication more effective because 
you can easily send marked up Tekla models to other project participants. 
To learn more, watch this introductory video .
         
                
Tekla Structures Model Reviewer includes excellent model navigation and 
mark up functionality. With it you can:

    * Easily pan, rotate, zoom, and fly through the model
    * See important part information
    * Fly through a set of saved locations in the model to present it to the 
project team
    * Use clip planes to slice through walls and crowded areas of the 
model
    * Email models easily to other parties
    * Create and manage markups (redlines) of specific areas in the model
    * Visually track project statuses with different colors in the model

Download Tekla Structures Model Reviewer

     
To view a Tekla web model with the Model Reviewer:

    * Save the model file (.wmr, .xml, or .zsol file) to your computer, e.g. to 
the desktop 
    * To install Tekla Structures Model Reviewer, click Free Download  
    * Browse for the model file, select it, and click Open

NOTE: Once the Model Reviewer has been installed, you can always 
open it again from Windows Start Menu > Programs > Tekla Structures > 

Tekla Structures Model Reviewer

For more information, see the online help.

If you have trouble with starting up this tool, check tool prerequisites in online 
help.

Do you have comments on this tool? Send us an email at: 
teklasupport@dowco.com  

See examples of Tekla web models

Some of the sample models shown below are available fro viewing using the 
Model Reviewer

Arvin Eugenio



New in V15.0, Backing up your FleXnet license(s)
One of the several benefits of the FleXnet License system is the ability to back up your license(s) in case of damage to your license server. This was not possible 
with a plastic dongle key, if the key was gone or damaged there was no way to get it working again. With the latest TeklaStructures License Manager (V1.13) you 
can now make a “dummy” copy of your license(s). This is not a working copy of your license(s), but if any thing happened to your License Server that caused the 
license(s) to be lost, you could fix the issue by using the new repair tool on this “dummy” copy. This means you can avoid losing valuable time, something you 
could not do using dongle keys.

To make a backup copy of your FleXnet license(s), on the acting license server(s), navigate to C:\Documents and Settings\All Users\Application Data. Create a 
copy of the FleXnet folder and all the files within to some type of portable media such as CD, DVD etc. It is advisable to make a couple of copies of the FleXnet 
folder, keeping one in the office and another off site in case of a major catastrophe. Including this folder in your daily backup routine is also a good idea which just 
gives you a little extra insurance. Any time the configuration of your license(s) changes you must make fresh backup copies.

 Note: If you cannot see the above folder structure, select “Show hidden files and folders” in the “Tools -> Folder options -> View”

To repair a license(s), with TeklaStructures License Manager (V1.13) installed, copy the saved FleXnet folder to the same folder location. When you launch the 
TeklaStructures License Administration Tool, it will detect the “dummy” copy and automatically start the repair process. Follow the on screen instructions and you 
will soon be up and working.

Remember to Backup your data

In today’s world of electronic data exchange, the ability to safeguard your data could not be more important. As a user of TeklaStructures all 
your hard work is in the end just files: TeklaStructures models (.db1), NC files, electronic drawings such as PDF’s or any other form of data 
extracted from the model. Add to this the integral part your model now represents in the BIM arena, your files are one of your most valuable 
assets and worthy of extra protection. No company can afford to lose files due to hardware failure, software issues, a virus or even user error. 
If you did, then you would not be able to deliver the project and thus not get paid. It is imperative that at least a daily backup of your files is 
performed. By backing up several times during a day on the most critical files, such as .db1, it is just extra insurance against the unexpected 

and will help minimize the potential of lose data.
For backup methods and strategies please contact: TeklaSupport@Dowco.com

Tom Knight

Tekla Structures and Fabtrol MRP – New Features and Important Notifications
Integration between Tekla Structures and FabTrol MRP
New features and important notifications

Do you do detailing in Tekla Structures for fabricators using FabTrol MRP? Over the past year, FabTrol and Tekla have continued to work together to find 
ways to improve the interoperability of their products. In Spring 2009, Tekla released Version 15.0 of Tekla Structures and FabTrol is releasing Version 3.0 
of FabTrol MRP. Included in the release of these new versions is a new format of the FabTrol‐Tekla Structures reports. 

Below is a list highlighting which options to use in Tekla Structures when exporting information to FabTrol MRP for the different stages of a project. 

FabTrol MRP Estimate
Found in the “File>Export>MIS” menu in Tekla Structures
•	 KISS File export Version 1.0

FabTrol MRP Advance Bill of Material (ABM)
Found in the “Drawings & Reports>Create Report” menu in Tekla Structures
•	 FabTrol_ABM_List‐v30.rpt

FabTrol MRP Detail Bill of Material (DBM)
Found in the “Drawings & Reports>Create Report” menu in Tekla Structures
•	 FabTrol_Assembly_BoltNutWasherStud_List‐v30.rpt
•	 FabTrol_Assembly_BoltStud_List‐v30.rpt
•	 FabTrol_Assembly_Parts_List‐v30.rpt
•	 FabTrol_Drawing_List‐v30.rpt
•	 FabTrol_Drawing_Revision_List‐v30.rpt

Important Notifications

There are a few important things to know regarding the new Version 3.0 report templates.

•	 The older Version 1.6 reports are NOT supported in Tekla Structures Version 15.0 and newer
•	 The older Version 1.6 reports are still supported in FabTrol MRP Version 3.0
•	 The new Version 3.0 reports are supported in FabTrol MRP Version 3.0

It will be possible for the new Version 3.0 reports, exported from Tekla Structures Version 15.0, to be imported into an updated version of FabTrol MRP 
Version 2.0. The update will be available from FabTrol by the end of May. 

The Version 3.0 reports can be copied into and run from earlier versions of Tekla Structures (potentially back to Version 11.0). However, the reports are 
officially released in Tekla Structures Version 15.0. KISS Version 1.0 files can still be generated from Tekla Structures and imported into FabTrol MRP.

An orientation mark  is a symbol (#32  in xsteel.sym ) 
that appears on one end of a member in the GA drawing 
and also in the corrsponding end of the main part in an 
Assembly drawing. These marks can be used to locate 
members in the field and assist the shop in placing the as-
sembly mark at the correct end of the part.  Before I con-
tinue with this article I must add that the preferred method 
for orienting a member that still remains is to use the Part 
Mark placed on the left end of the beam. Part Marks in 
Tekla Structures tend to adhere to the Starting end of the 
Member but manual checking must still be done.

 
Simply put: The ideal situation is to always have the Orientation Mark appear 
on the same end as the Start Point Handles for beams in a GA drawing. This 
cannot be guarranteed to always work out if the modeling has not been done 
according to strict methods . We will say you must still check the  orienation 
manually to be sure. Certain mirrored items  may not adhere to the rule as 
well. Nothing can beat manual inspection of course.
 
GOOD MODELING PRACTISE

The following is a suggestion for modeling practise that will improve the dis-
play of orientation marks for proper erection placement will accurately locate 
the parts in the field. The degree of accuracy surely depends on the adher-
ance of the modeler to the rules stated below.
 
SETUP

Tools>Options>Orientation Marks
Use the default geographical settings of North=90 degrees (Compass Direc-
tion)
Orientation marks always appear in the West or South ends of beams re-
gardless  of the way they are modeled. Set also Preferred location for mark 
= Left.
  
MODELING PREFERENCES
 
1. Beams are to be modeled:
 a. from West to East (Left to Right) with the Start Point at the Westerly end.
b. from South to North (bottom to Top) with the Start point at the Southerly 
end.

2. Skewed Beams in Plan View change the direction from West to South at 
135 degrees and 225 degrees counter-clockwise from the +x axis in the plan 
view.  This diagram can be used by the modeler to determine the correct 
Starting Point for skewed beams. 
 
  
TEKLA HELP TOPICS  FOR ORIENTATION MARKS 

Orientation symbol 
Setting up orientation marking  (preferred location for mark)  
Compass Direction
 
ASSEMBLY DRAWINGS 

Assembly drawings should normally display the main part with the orienta-
tion mark on the left end of the main part. The View properties for the As-
sembly drawing should  be set to “Local” (which is the default  for all but 
channel drawings .) 
 
To turn “ON” the orientation marks in assembly drawings you go to the draw-
ing properties and select the PART button. There you will see a checkbox for 
the orientation mark. 
 
When reviewing Assembly drawings always look for the orientation mark to 
be on the LEFT end in the  shop drawing. In cases where this is not so you 
should go  back to the model and swap the handles for that beam and re-
number using automatic cloning.

Dave Berryman, Tekla Structures Technical Support

 TROUBLESHOOTING THE GA DRAWING

There is a macro available called StartPoint_checker.cs and StartPoint_Deleter.
cs See C:\TeklaStructures\14.1\environments\usimp\macros\drawings
You can run this macro  (listed below)  against a GA drawing to see if the Start 
Ends coincide with the Orientation marks. 
 
MACROS YOU CAN USE

1. In the modeling area there is a macro called Tools > Macros > Swap Handles  
This allows you to change the start point for a member. Renumbering is re-
quired if you use this
 
2. In the Drawings there is a macro called Tools > Macros > StartPoint_checker
This places a recognizable symbol  (symbol #21 in xsteel.sym)   on the Starting 
end of each member in the GA  and allows you to compare it with the Orienta-
tion Mark. They should be at the same end of the beam. 
 
 3. And also StartPoint_remove. After you have reviewed the entire GA drawing 
you can remove the Start Point symbols from the GA drawing.
 

CHANGING THE ORIENTATION MARK  APPEARANCE 

This mark is #32 in the xsteel.sym file. It is designed to be off center so the 
triangle inside the circle acts as a pointer. If you wanted to change the symbol 
and have a solid circle on centerline of beams in a GA then use symbol #17 and 
place this variable in the user.ini or in the Tools > Options > Advanced Options 
> Marking Parts . 
 
For GA Drawings  (in your Advanced Options) 
XS_GA_NORTH_MARK_SYMBOL=17  
(this is a heavy black circle that is centered on the beam symbol)     
By default, the symbol for hidden North marks in general arrangement drawings 
is number 32 in the xsteel.sym symbol file. To change the symbol, set the vari-
able to a different symbol number.
 
For Assembly Drawings (in your Advanced Options) 
XS_NORTH_MARK_SYMBOL= 32 
You can use #17 also if you want the symbols for Assembly Beams to be the 
same as you used in the GA . The default is #32 in xsteel.sym . You could also 
edit the actual symbol #32 but we do not reccomend this. It is best to create the 
exact symbol you want and call it from the Advanced Options. 
 
CHANGING THE ORIENTATION MARK  COLOR

Sometimes you may want the Orientation mark to stand out in your drawing 
views. For example, your part color could be green and the orientation mark = 
red.  To do this you must edit the color of  #32 in the xsteel.sym file. Open the 
#32 symbol in the Symbol Editor and double-click each element in the symbol 
editing pane. A popup form will allow you to select a color for that portion of the 
orientation mark graphic.

Using Orientation Marks


